Wednesday, October 26, 2011

Unable to use SQL Server because ASP.NET version 2.0 Session State is not installed on the SQL server. Please install ASP.NET Session State SQL Server version 2.0 or above

While I am trying to use sql server authentication mode, i got the following error
Unable to use SQL Server because ASP.NET version 2.0 Session State is not installed on the SQL server. Please install ASP.NET Session State SQL Server version 2.0 or above.
Cause: If your application is suppose .Net 4 then you need to take the InstallPersistSqlState.sql of the Framework64 version.
Solution: So go to C:\Windows\Microsoft.NET\Framework64\v4.0.30319 and from there take the InstallPersistSqlState.sql, it will work fine.